I’ve come across a problem a few times using Workbench when trying to connect to servers only to be told I can’t because there is a version number mismatch (even though both Workbench and the server are at the same service pack level).  One way around this temporarily (if you know the versions are the same but for some reason the server version is being reported incorrectly) is to disable the compatibility check in Workbench:

  1. Open your workbench.ini file (usually located in C:\Users<user_name>\Apps\Adobe LiveCycle Workbench ES3\workbench
  2. Locate the line “-Dcom.adobe.connection.compatibilitycheck.disable=false
  3. Change the value to “true”
  4. Open Workbench and try to connect to the server again